Pelco Developer Network (PDN)

Error installing SDK that .NET 4.5.1 is required, but 4.5.1 is installed...

Hi.
When I try to install the latest Pelco SDK (4.1.0) I get an error:

---------------
Pelco SDK - InstallShield Wizard
.NET Framework version 4.5 or 4.5.1 is required in order to continue with the installation.
---------------

Yet 4.5.1 seems to be installed, along with 4.5, and probably 4.6 (since this is a Windows 10 machine).

I see it is a common problem, but has anyone found a fix for this?
-- thanks

I have hte same problem, on windows 7 machine.

Trying to uninstall the Pelco SDK to install the new one and unable to uninstall.

It is required to have the .NET 4.5 or 4.5.1 specific framework also on the PC running the SDK (or Redist or Tools like SDK logging).

You'll have to work with the OS specifically to get the proper .NET version installed on the PC running these tools. You can start on the MSDN website for how to do this - simply downloading the .NET Framework and running an installer typically results in an error saying that a newer version is already installed. Here is a good place to get started: https://msdn.microsoft.com/en-us/library/hh506443(v=vs.110).aspx (replace the .NET 3.5 notes with the version you need).