Pelco Developer Network (PDN)

exported mkv zip file via SDK cannot be extracted

Hello there, thank you for your post.

There isn't a lot of information go off of with your post... anything more would help. Do you have screenshots that you can attach? Do you have VX SDK logs that you can provide? Is there any specific error message of any kind?

We'll need more information than just a subject line in order to help out further.

exported mkv zip file via SDK cannot be extracted

I was experiment Pelco code (VxSdkNet-ExampleClient) hoping find pieces I can use, I see an issue that export a recorded video to disk as a .zip file, but when unzip I get below error.

see attached screen shot

Admin edit:
link: cannot-extract-zip.png
cannot extract zip

Hello there, thanks for your post. Since this post was originally created 9 months ago, I'm going to guess that you're having a problem similar to the original poster and saw the subject for it and decided to post.

Some questions to get answers to:
Are you able to use VideoXpert Ops center to export video from VideoXpert successfully?
Can you download the ZIP file from that export and extract the MKV file from the ZIP when using VideoXpert Ops Center?

If the answers to these questions are "No" - then please reach out to Pelco Support for further troubleshooting. It would appear that exports in your system are having a problem and the problem isn't limited to using the VX SDK.

If these exports when using VideoXpert Ops Center do work successfully, we'll move on to trying to troubleshoot the SDK exports. Using the sample code, it is possible to view the system's prepared exports and Download one of them.

Test 1: download the same export that worked when using VX Ops Center using the VX SDK sample. Does the downloaded ZIP file successfully allow viewing of the MKV media file?

If "No", then I'd ask for vxsdk logs (default location is in ProgramData\Pelco\vxsdk\logs, and set the LogLevel to TRACE), and also please tell me what versions of VideoXpert are in use, and what version of VX SDK.

If "Yes", and this export does work, then please perform another test:
Test 2: create an export for the same time period using the VX SDK, and please let me know the results of trying to get the same export using the SDK. If it does not work and continues to give the same error (and the VX Ops Center export does work properly, this is KEY), please provide to me what versions of VideoXpert are in use, what version of VX SDK are you using, and vxsdk logs from the attempt. It would be most helpful to put the LogLevel to TRACE, also.