Pelco Developer Network (PDN)

Pelco SDK feature tester error

I am trying to test and confirm that the Pelco SDK is working using the Pelco SDKfeature tester but I seeing a Microsoft C++ error

Installed software:
PelcoSDK-4.2.1-15974.vc10
PelcoSDK-Redistributable-4.2.1-15974.vc10
PelcoSDKFeatureTester-4.2.1-15961.vc10

See attached screen capture for error.

What is this error related to? Is there a particular versions of Microsoft C++ Redistributable needed? The OS is Windows 7 32-bit.

errorPelcoTester

Hello there!

I edited your post to display the screenshot, so that others could see what you attached. Adding attachments is a little odd on our forums; you have to choose file, upload it, and then use the insert/edit image and use the url from uploading the image into the body of your post.

There are software requirements when installing and using the Pelco SDK. You can find this information on the SDK Documentation page here: SDK Documentation. Specifically you must have the x86 C++ Redist Package for Visual Studio for either 2013 or 2010 (depending on which VC12 or VC10 version of the Pelco SDK). It looks like you'd need the Visual Studio 2010 version based on the SDK versions you listed.

Please review the requirements in the SDK Documentation, and let me know if you have more questions or if your issue becomes resolved.

Hi Chris, thanks for your reply. We are using VC10 of the Pelco SDK. I checked and x86 Visual C++ Redistributable Packages for Visual Studio 2010 SP1 is already installed. I have attached a screen capture. What could be causing the error?

vstudio

Oh, you know what - I thought of something else that could be causing a problem.

In your original post, you mentioned that you have PelcoSDK and Pelco SDK Redistributable installed. I suggest running your tests without the SDK Redist installed (or uninstall the Pelco SDK and try using only the Redist installed). When you install Pelco SDK, there is a string added to the Environment Variable PATH in Windows OS. There may be conflicting strings in the PATH that are each trying to point to Pelco SDK or the Pelco SDK Redist files. I'd suggest trying your test with only one or the other installed. Review the Environment Variable PATH to ensure that there is only one string pointing to SDK files, and be sure that it is pointing to \Release files when using the Feature Tester.

If you still encounter problems with this ... then install and use only Pelco SDK and utilize the Pelco SDK Logging Executable from the Logging folder. It should generate a PelcoSDK.log and MPF.log if you click all of the options and then try running the Feature Tester.

I can confirm that there is only one string pointing to the Pelco SDK files. On my laptop, I have both Pelco SDK and SDK Redistributable installed but I am not seeing the error. I checked and it has the same Pelco related strings.

Below is the strings from the computer having the problem.

C:\Program Files\Pelco\API\PelcoSDK Redistributable\Libs;C:\Program Files\Pelco\API\Libs\Debug;C:\Program Files\PHP\;C:\ProgramData\Oracle\Java\javapath;C:\Program Files\Pelco\Common Files;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\Program Files\QT Lite\QTSystem;C:\Program Files\Microsoft SQL Server\110\Tools\Binn\;C:\Program Files\Microsoft SQL Server\110\DTS\Binn\;C:\Program Files\Microsoft SQL Server\Client SDK\ODBC\130\Tools\Binn\;C:\Program Files\Microsoft SQL Server\130\Tools\Binn\;C:\Program Files\Microsoft SQL Server\130\DTS\Binn\;C:\Program Files\Microsoft SQL Server\130\Tools\Binn\ManagementStudio\;%systemroot%\System32\WindowsPowerShell\v1.0\;%systemroot%\System32\WindowsPowerShell\v1.0\;C:\Program Files\1E\NomadBranch\;C:\Program Files\QT Lite\QTSystem\

And this is from my laptop that does not have the problem

C:\Program Files (x86)\Pelco\API\PelcoSDK Redistributable\Libs;C:\Program Files (x86)\Pelco\API\Libs\Debug;C:\Program Files (x86)\Pelco\Common Files;C:\Program Files (x86)\PHP\;C:\Program Files (x86)\Intel\iCLS Client\;C:\Program Files\Intel\iCLS Client\;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\QT Lite\QTSystem;C:\Program Files (x86)\Box\Box Edit\;C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files (x86)\Lenovo\Access Connections\;C:\Program Files (x86)\LonWorks\bin;C:\Program Files (x86)\WorkPlace Tech\Licensing\Core;c:\Sigma\bin;C:\Program Files (x86)\Pico Technology\Pico Full\;C:\Program Files (x86)\Pico Technology\PicoScope6\;C:\Program Files (x86)\LOYTEC\NIC\Windows\bin;C:\Program Files (x86)\WebEx\PTools020000000;C:\Program Files (x86)\Skype\Phone\;C:\Program Files (x86)\Microsoft SQL Server\110\Tools\Binn\;C:\Program Files\Microsoft SQL Server\110\Tools\Binn\;C:\Program Files\Microsoft SQL Server\110\DTS\Binn\;C:\Program Files (x86)\Microsoft SQL Server\110\Tools\Binn\ManagementStudio\;C:\Program Files (x86)\Microsoft SQL Server\110\DTS\Binn\;%systemroot%\System32\WindowsPowerShell\v1.0\;%systemroot%\System32\WindowsPowerShell\v1.0\;C:\Program Files\1E\NomadBranch\

The only difference I can see that 'C:\Program Files\Pelco\Common Files' is not immediately after 'C:\Program Files\Pelco\API\Libs\Debug;C:\Program Files\PHP\'. Does the sequence matter?

The sequence shouldn't matter, no. Feel free to try things out to see if you notice a difference.

I tried this a bit today ... we haven't done any work with pelco SDK or its tools in quite a long time time. I did still have Pelco SDK installed, and after launching the SDK Feature Tester, within just a few seconds I also had the error pop up.

This is what I tried, and it worked for me: I changed the PATH to point to PelcoSDK "...\Libs\Release" instead of the Debug folder. I also do not have Pelco SDK Redistributable installed. After I changed Debug to Release in my Windows Environment Variables and launched the SDK Feature Tester, I did not receive the crash message after several seconds like I was getting before.

Please give that a try and let me know the results. If that doesn't work, I'm really not certain where to go from here - we haven't worked on or done support for Pelco SDK in some time now.

Hi Chris, the error was resolved after uninstalling Pelco SDK leaving only the PelcoSDK Redistiubutable. many thanks for your help :)

Hi Chris, the error was resolved after uninstalling Pelco SDK leaving only the PelcoSDK Redistiubutable. many thanks for your help :)

Great! Thank you for reporting success and resolution with this issue. I'm glad to hear that it is working properly for you now, happy to help.