Pelco Developer Network (PDN)

Pelco SDK PelcoMediaControl.ocx usage problem

In order to use PelcoMediaControl.ocx in our VBA application, we install .NET framework 4.5.1 developer pack and then install Pelco SDK. After that we open our VBA application and execute it and it failed to execute.

But when we install visual studio 2013 community edition and then install Pelco SDK, Our VBA application works successfully. Is it essential to install visual studio in order to use PelcoMediaControl.ocx in our VBA application?

Similar to my reply to your other post here, I want to ask similar questions:

What VMS are you writing a solution to work with? If you are using VideoXpert. newer versions are steadily having more problems with past developments that used Pelco SDK.

We do not encourage using the old Pelco SDK, and we have not done any development or support for new efforts using these tools in a long time. This includes the OCX that was not updated even in the last few releases of Pelco SDK, but only included for project solutions that used it previously.

In other words, we can't make any claims that it would work in more current dev studios or Operating systems. As time passes, there will be more and more problems trying to use it. Use it at your own risk. There are logging tools included with Pelco SDK, and perhaps using Wireshark or Windows Event Viewer you can discover more information about why the crash is happening.

Thank you Chris for reply, but we must use old Pelco SDK in this stage.We just solved big problems and only have one remaining.

The problem is the existance of VisualStudio 2013. When we install Visual Studio 2013, PelcoMediaControl works very well, but it doesn't work without VisualStudio. I added the log of Pelco when we run it without Visual Studio.Could you check it ? We do all registrations of Pelco. What Visual Studio adds for Pelco ?

PelcoSDK.txt

Thanks for your reply. I am sorry to hear that you must use Pelco SDK ... I'll answer what I can to help you out -- please keep in mind that we are no longer providing active development or support for it as our focus is VX SDK for VideoXpert.

Regarding Visual Studio 2013 - installing Visual Studio 2013 -OR- the x86 Visual C++ Redistributable Packages for Visual Studio 2013 is a requirement for using Pelco SDK. This requirement is listed in the Quick Start guide here: Pelco SDK 4.2.1 Quick Start Guide under 'Deployment Dependencies". This might be what is missing that is resolved when you install VS2013. You may be able to only use the x86 Redist for VS2013.

Unfortunately I cannot answer your question: "What Visual Studio adds for Pelco?" - there are no active developers at Pelco that worked on developing Pelco SDK. I do know that VS2013 is a requirement for the VC12 version of Pelco SDK. Based on the log file (I edited your post to link it so it can be viewed), it looks like PelcoAgg.dll requires some files that were not there. I might suggest using Depends.exe, if you want to investigate further what VS2013 files might be required by PelcoAgg.dll that might be resulting in that crash. I believe that's the best tool for tracking down dependencies that might be missing. This investigation is entirely up to you, I probably wouldn't worry about it.

You may only need to worry about installing VS2013 or the x86 Visual C++ Redistributables for Visual Studio 2013 for things to work properly.