Pelco Developer Network (PDN)

RTSP Server for playback streaming

Hi,

I am currently trying to play a playback stream on VLC or even sent it to my video server. I have found some mention on RTSP server( http://pdn.pelco.com/content/rtsp-server#sthash.i1jxOMAb.dpbs) which seems to be capable of doing this (http://pdn.pelco.com/content/rtsp-server-usage#sthash.HZaBsavK.dpbs). I have tried and and successfully stream a playback from 1 day ago. But when I tried to playback a stream from this morning, it failed. Is there a limitation on the datetime for the playback using RTSP server or can this be configured somehow?

Thanks and Best Regards

Hello there!

Thanks for the post. What VMS system are you expecting to have this set up with - a Pelco one (which one), or one of your own?

RTSP Server details at that link is pretty old and deprecated. It was an implementation on Pelco NSM recorders, where the RTSP server was installed and you would then use those constructed strings to retrieve playback video. If you are using an Endura VMS system ... you might try using this approach still as (to my knowledge) RTSP server started to be installed by default on Endura NSMs as of a specific version. A check on Pelco.com for NSM firmware version release notes may indicate which version.

If you are integrating with a VideoXpert system, then we strongly recommend using the VX SDK to do so. This SDK is capable of obtaining the RTSP streams that you need for you to then use in a video player of your choice.

For your question specifically about limitations on datetime or configuring it; there are not options to do this as far as I'm aware. There may be explanations why the playback didn't work to retrieve the playback for this morning. You might try using Wireshark (if possible, depending on where you trying to get the stream from) to see if you can determine why the failure occurs. Check the responses - again if possible - to the RTSP OPTIONS, SETUP. PLAY requests to see if you can find out what the problem was there.

Hi Chris,

Thanks for the response. By trial and error, I found out that the reason I was not able to receive any stream was due to the datetime specified. Apparently it follows UTC format and due to that the datetime I specified in my stream request is actually +8 hours later, thus no recording is yet to be available. Sorry to bother you with this rookie mistake. Thanks for your help though, much appreciated.

Best Regards,
M.Syafiq

Ahh, gotcha. Thank you very much for the update. I'm glad that you were able to determine what the problem was, and I do appreciate you posting the results here as well to help out anyone else who may also encounter this problem in the future, just in case.

Thanks!

Hi Chris,

I have one more question on the RTSP Server for playback. Is there any limitations on the number of connections to the RTSP Server and will connecting to the RTSP Server affect any recording being done in the NSM? Thanks for your help.

Best Regards

Hi there!

Sadly I didn't have the information available to me, so I started looking to see what I could find. On the Pelco.com Knowledge base I did find an article that might help and pertain to what you're working with. Please have a look at the article here at this link from the Pelco Knowledge Base:

Error when Attempting to View more than Four Streams Using the RTSP Server on an NSM5200

it sounds like, at the time of that article at least, RTSP Server on the NSM is set to send 4 streams maximum. That can be configured. For further questions about it, I suggest that you reach out to Pelco Product Support (since my information is limited in this regard). Connecting to the recorder using RTSP should not impact recording ... otherwise the service would be not as valuable. For additional info though, once again I'd suggest reaching out to Pelco Product Support.

Hi Chris,

The article is very helpful in addressing my issue. Also as you recommended, I'll reach out to Pelco Product Support for more enquiries. Thank you, I really appreciate your help and the effort you have put it.

Best Regards,
M.Syafiq

Sounds like a plan, sure thing!