Pelco Developer Network (PDN)

Unable to Install Pelco SDK

Hi All,

I am having trouble installing the PelcoSDK-Redistributable-4.2.1-15974.vc12.exe. When I tried installing, the it says installer is interrupted as shown below:

error

I have already check that I have DirectX version 11 installed and also VS C++ Redistributable x86/x64 installed. I saw in the requirements that this SDK can be installed in Windows Server® 2012. But the OS I am using is running Windows Server® 2012 R2. Is it possible to install to Windows Server® 2012 R2? Am I missing some other prerequisites? Or is this caused due to some permission access issues? Please help. Thank you.

Best Regards,
M.Syafiq

Hi All,

I have managed to install the Pelco SDK. But I now am facing a new problem. My program is a website hosted in IIS, when my application tried to initialise the Pelco SDK using this C# code : Pelco.SDK.Application.Startup(), my application will give the following exception: External component has thrown an exception. Is this due to the application being unable to find the installed Pelco SDK dll?

PS: I have already ensure that my application running release version and that the Pelco.Sdk.dll reference is a release version dll. I have also check that the string in PATH is pointing to D:\Program Files (x86)\Pelco\API\Libs\Release.

Thanks and Best Regards,
M.Syafiq

It sounds like the SDK is still having a problem that could be related to locating, accessing, or running the Pelco.SDK.DLL in your application. Below are a few suggestions that you can check to see if any resolve your issue as you explore your environment. Some of these suggestions you may have tried already; you'll know your environment better than I will :).

--Double check that there is only a single string for the SDK PATH in your environment variables. Sometimes if you switch between SDK versions (uninstall / reinstall) this can occur.

--Run depends.exe on the Pelco.SDK.DLL at the file path that your project is pointing to and ensure that no specific files are missing from that dependency.

--Completely uninstall any/all versions of Pelco SDK, check environment PATHs to be sure they are gone, delete any leftover SDK directories, check Program list (Add / Remove programs) to ensure all Pelco SDK installs are gone, reboot and reinstall. Then check and see how things run.

--Try running sample code from Pelco SDK install to see if the problem exists with the sample code. Ensure that this is working and not crashing or having an issue before returning to your project.

An external component exception like what you are seeing is very often a mismatch between debug / release - I do see that you checked several spots already. If there's an extra string in the PATH it might cause an issue, or additional installs of Pelco SDK on that PC that cause confusion during run time.

-- Check all of the environment variable paths to ensure that the proper ones for release/debug all exist (including the EVEREST) ones. See this screenshot from the SDK quick start guide:
Quick Start Guide - Paths