Pelco Developer Network (PDN)

VideoXpert SDK Install/Update procedure

VideoXpert SDK 2.0 installation

Please advise the right procedure for update from VX SDK v1.x to VX SDK v2.0:
can I directly update my VX SDK 1.x to version 2.0 (without uninstalling it), or do I have to uninstall VX SDK v1.x and after that install version 2.0?

Edited: sorry, I did forget about one change between these versions.

You should uninstall the existing VX SDK and then install the new one. Additionally, you may have to update any references to CppRest dll since that was updated to a newer version.

As far as an existing project goes, there are some differences. There may be minor changes that could need to happen with a developed solution, but we do not expect major changes or differences.

Hi,

I have uninstalled the old version and installed the new one according to your instructions. Everything seems to be good - the example is compiling and running. I still didn't check connectivity with real VX/VXPro system and the functionality of the sample, but it is compiling and running, which should be enough.

I noticed that there is something different during this install. I haven't been asked for VX SDK Key generation. In addition I have checked the sample and I do not find the function that is checking for the VX SDK key (in the MainForm.cs code) and this is teling me that we do not need this key anymore.

Please advise am I right (we do not need this key anymore)?

That's correct - this has been removed as of this last VX SDK version.

It will return later when a different key and process has been implemented.

I have tried to connect to a real VX system and i received a run-time error:

"Could not load file or assembly 'CSharpWrapper.dll' or one of its dependencies. The specified module could not be found.":"CSharpWrapper.dll"

I believe this is related with these two dlls: cpprest120d_2_9.dll and VxSdkd.dll

I couldn't find any references to these dlls in any example. they was just copied in the same directory where the CSharpWrapper.dll is (in the bin directory). I did the dame, but the error still remains. I have set my solution to x86 CPU type, Active(Debug).

I have also added the VX SDK path to these two dlls (in the Debug directory) to the environmental PATH variable, but it didn't help.

Please advise what might be the problem and how to solve it?
And do I need this CSharpWrapper at all (I am developing on C#, using VS2013)?

Thank you in advance for your prompt reply!

Hello -

Did you download the latest set of sample code from the Github repository? I saw the error you're describing with old sample code during our testing, and it was later resolved with the newer batch of samples.

To test I just downloaded the latest Github samples available (look under VX SDK on the left-hand menu here on PDN and the Samples link). After downloading the zip file and unzipping it, I opened up the CSharpSample120 solution using Visual Studio 2013 project specifically which included CSharpWrapper and MediaController projects. I built the project with no issues, then was able to start it and connect to our VideoXpert system and stream video.

The CSharpWrapper is a part of that sample project and is needed for it, yeah.

It sounds like it may be a problem with the Sample code that you are using; either it is old or perhaps not the latest samples that are available on our Github repo.

Also you shouldn't need to add the environment PATH to Windows like the older Pelco SDK, that isn't a requirement for the VX SDK (only state this so you know for future reference -- good idea).

Hi,

I download now the samples from this page on PDN : http://pdn.pelco.com/content/videoxpert-sdk-related-downloads, clicking the "Sample Code" link (below the release notes link) - see attached png screenshot.
It re-directs me here: https://github.com/pelcointegrations/VxSDK-Samples
I hope this is the latest sample code (it states that it is updated 6 days ago) and will try testing it today.

If this is not the link for the latest sample - please send me the link!

Yep - that's the correct place to go.

Thank you! Will install it today and check.

Hello, I have a problem with VX SDK integration.
I downloaded the sdk and sample code (https://github.com/pelcointegrations/VxSDK-Samples), but when I run the example (csharpsample - > CSharpSample120) in Visual Studio 2017, it does not compile. Judging by the errors in it there is no CPP Cli, I found this dll in another project on github and added to the project, but to no avail the errors remained
Perhaps I'm doing something wrong and so I ask you to help me with the integration.

A screenshot of the error
Errors

Hello there, thank you for your post, and definitely thank you for the screenshot (I know that the system isn't intuitive).

The Vx SDK that is available today (August 2018) does not have built in support for Visual Studio 2017. Please see the ReadMe file in the Samples page here: https://github.com/pelcointegrations/VxSDK-Samples: "Visual Studio 2013 and Visual Studio 2015".

The next version of the Vx SDK that is currently being updated to accompany VideoXpert 3.0 will have support for Visual Studio 2015 and Visual Studio 2017. I do know that some people have been able to get it to work by replacing some of the System.Net references to the correct and proper VS2017. From your screenshot, it's probably System.Net.Http.Formatting.

Hello, I have removed some bugs thanks to your answer, but failed to compile the project. I also made compatibility with vs 2015 And it also didn't help. Here is a screenshot of the error
Error

You'll need to have the NuGet packages load properly for the project. I tried things out today and had similar error messages in my Output when I tried to build the GitHub samples using VS2017 (which again; the SDK is only supported in VS2013 & 2015).

This was what *I* had to do to correct the problem; navigate to the NuGet Packages and install Microsoft.AspNet.WebApi... specifically the .Client version. For me I had to install this on CSharpSample140 project so that System.Net.Http.Formatting would be properly linked and found, and then the rest of the project built properly. Here's a screenshot:

NuGet Browser - Microsoft.AspNet.WebApi.png

I must reiterate that this was what worked for ME. Your setup, system, and environment could be different than mine (no doubt it is). At the end of the day, this is a linking and environment issue because you're trying to use this in VS2017, which the Vx SDK - today - wasn't built for. Our next version that we will release will have support for VS2015 & VS2017.

I should have mentioned it before too, but I didn't expect to go into quite this much detail on this forum post... but we probably should ask to create a new post for new issues, rather than post on an existing one. Other posters may be receiving notifications on their over 1-year old post about this new issue, so we probably should have just created an entirely new post. Next time, let's do that instead.

Thanks!