Pelco Developer Network (PDN)

Where to look for logs

Since upgrading to version 2.5.x.x of VXpro I got an new issue with live streaming stopping unexpected, clock stops picture freeze. Where can I find some logs telling something about the "chrashes". It was not a problem in the previus version. As I see it GStreamer is the same version.
I inspected the live stream example grom github, could not see any difference in how to set up a live stream from the version my live software is inspired from. I upgraded theVX SDK of course and recompiled the project.

Greetings

Thanks for your post, I'm sorry to hear about the problems that you're seeing with the new version.

There are two places that you can go to find logs, and they all should be in ProgramData\Pelco. Since you're running Pro, there should be a folder for logs in ProgramData\Pelco\ProServer\logs. Additionally, for VX SDK-related issues, the default logging directory Path (this can be changed using the SDK) is ProgramData\Pelco\VxSdk\Logs.

Do you see this same behavior of the stream stopping when you use Ops Center with VideoXpert Pro in your setup? It might be the same if you're using the VX SDK (which is using GStreamer) as when you use Ops Center -- which also uses GStreamer at it's basic levels. Trying the same tests in Ops Center that you'd test when using the VX SDK is often a good idea. There are additionally logs for Ops Center in ProgramData\Pelco\OpsCenter\Logs, too.

For additional information when using the VX SDK and GitHub samples, you might try changing the logging to Trace (or alternatively try some others too, in order to gather information: Debug, Info, Warning, Error, etc), and then review the Vx SDK logs. The option to change the logging level with the Vx SDK samples is under the File>VxSDK Log Level toolbar menu when the application is started. It's important to point out though that the Vx SDK doesn't provide streaming natively -- since it's all GStreamer you may not find much in the logs, but it's worth trying.

If you do determine that this is related to the VideoXpert Professional installation or setup, I would also encourage you to reach out to Pelco Product Support for further help with VX Pro specifically: https://www.pelco.com/support.

Just to close the thread. Pelco Spectra IV cameras withTXB-N IP encoders has a setting for stream = H264, when using this the 2.5.x.x version and SDK 2.1 for live stream, I get stability problems. The picture freeze/stops. Change to MPEG4 problem solved.

Interesting. Thank you for posting this information in case anyone comes across this in the future.

Running for a couple of days, the MPEG4 stream is not good either. It reduces the error, but it does not remove it. Most seen on Spectra IV - with TXB-N ip encoder.

Think I will start a support case. The developers at VXpro server must have changed something fatal from previus version till latest version.

Interesting note. Yes -- please do contact our Support teams so that they can investigate with you, that is the best route to start work so that their teams are aware of the issues that are being seen.